Welcome to the in5 Answer Exchange! This a place to get answers about in5 (InDesign to HTML5) and make requests.
0 votes
I frequently encounter a bug when exporting, where the plus buttons on the resources tab of the export dialog don't work, preventing me from including necessary css and js files. It's inconsistent as to when it happens, restarting InDesign or my computer doesn't always fix it. I am using the most up to date version of in5 (3.8.12).
in bugs by (190 points)
reshown by
  

1 Answer

0 votes
Make sure that you're running InDesign as administrator. 
Here is information on how to run InDesign as administrator on macOS:
by (29.5k points)

We haven't gotten any other reports about the buttons to add Resources not working in any of the recent versions of in5. There was a report about 2.5 years ago where installing 3.7.3 seemed to fix it. You might try uninstalling in5 and reinstalling it.

Are you running any sort of antivirus? We've seen that affect users' ability to download updates via in5 > Info and Updates... or Scrolling Frames via in5 > Interactive Widgets > Scrolling Frames.

I haven't seen that behavior. If you notice the buttons not working with particular InDesign files, it may be that those files have become corrupt. You could try saving them as an IDML file and back as an INDD file:

Sounds good. And please keep us posted if you notice anything else that might be affecting the availability of the + buttons in Resources. :)
Thanks for these details. We'll keep an eye on this and see if we can find a way to replicate it.

We still haven't been able to replicate this bug.

Would you be able to send us the following additional information where you're seeing the issue?

  • Your version of InDesign 
  • Your Operating System and version
  • Your anti-virus software
We'd also be happy to take a look at your InDesign file, if you can send it or a sample of it that recreates the issue. You can send it to us here:
I'm checking with Justin to see if he has any additional recommendations.
Justin said he wouldn't be have any additional recommendations until we can replicate the issue with consistency.

I would suggest making notes of any details you can about your environment or steps you take that would help us to replicate the issue.
will do, but its been difficult to replicate on our own as well.
Thank you. And I'm sorry that you're still having this issue.
I think i've figured out what triggers the buttons from not working, and it seems to involve hitting cancel, possibly after choosing the Destination Folder location and creating a new folder name. I don't know if it will help but ill send my data file
Thank you for sending your data file. I'm checking with Justin about it.